[obsoleted] Caution: Battle.Net is not compatible with the latest beta build of OSX 10.10.3 (14D98g)

Problem:

  • All games in Battle.Net cannot be started. An Update button is shown instead of Start.
  • Update process cannot be done. A message will be provided indicating a permission error.
  • If you managed to reinstall the whole Battle.Net app, more problems about permission will occur.

Solution:

Go back to OSX 10.10.2 with your backup. Or, wait for Blizzard updating. No official statement made yet.

 

Leave a Reply

Your email address will not be published. Required fields are marked *